diff fixincludes/configure.ac @ 111:04ced10e8804

gcc 7
author kono
date Fri, 27 Oct 2017 22:46:09 +0900
parents f6334be47118
children 1830386684a0
line wrap: on
line diff
--- a/fixincludes/configure.ac	Sun Aug 21 07:07:55 2011 +0900
+++ b/fixincludes/configure.ac	Fri Oct 27 22:46:09 2017 +0900
@@ -6,6 +6,7 @@
 m4_sinclude(../libtool.m4)
 AC_CANONICAL_SYSTEM
 AC_PROG_CC
+AC_USE_SYSTEM_EXTENSIONS
 AC_PROG_SED
 
 # Figure out what compiler warnings we can enable.
@@ -52,7 +53,8 @@
 	i?86-*-msdosdjgpp* | \
 	i?86-*-mingw32* | \
 	x86_64-*-mingw32* | \
-	*-*-beos* )
+	*-*-beos* | \
+        *-*-*vms*)
 		TARGET=twoprocess
 		;;
 
@@ -94,7 +96,7 @@
 AC_C_CONST
 
 # Checks for library functions.
-gcc_AC_FUNC_MMAP_BLACKLIST
+GCC_AC_FUNC_MMAP_BLACKLIST
 
 AC_MSG_CHECKING([whether to enable maintainer-specific portions of Makefiles])
 AC_ARG_ENABLE(maintainer-mode,
@@ -112,6 +114,9 @@
 AC_DEFINE_UNQUOTED([SED_PROGRAM], "${SED}",
    [Defined to the best working sed program on the host system])
 
+# Determine what GCC version number to use in filesystem paths.
+GCC_BASE_VER
+
 AC_CONFIG_HEADERS(config.h, [echo timestamp > stamp-h])
 AC_CONFIG_FILES(Makefile mkheaders.almost:mkheaders.in)
 AC_OUTPUT