diff mlir/test/mlir-cpu-runner/CMakeLists.txt @ 150:1d019706d866

LLVM10
author anatofuz
date Thu, 13 Feb 2020 15:10:13 +0900
parents
children 0572611fdcc8
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mlir/test/mlir-cpu-runner/CMakeLists.txt	Thu Feb 13 15:10:13 2020 +0900
@@ -0,0 +1,15 @@
+set(LLVM_OPTIONAL_SOURCES
+  cblas.cpp
+  cblas_interface.cpp
+  mlir_runner_utils.cpp
+  )
+
+add_llvm_library(cblas SHARED cblas.cpp)
+target_compile_definitions(cblas PRIVATE cblas_EXPORTS)
+
+add_llvm_library(cblas_interface SHARED cblas_interface.cpp)
+target_link_libraries(cblas_interface PRIVATE cblas)
+target_compile_definitions(cblas_interface PRIVATE cblas_interface_EXPORTS)
+
+add_llvm_library(mlir_runner_utils SHARED mlir_runner_utils.cpp)
+target_compile_definitions(mlir_runner_utils PRIVATE mlir_runner_utils_EXPORTS)