diff clang-tools-extra/clangd/test/CMakeLists.txt @ 207:2e18cbf3894f

LLVM12
author Shinji KONO <kono@ie.u-ryukyu.ac.jp>
date Tue, 08 Jun 2021 06:07:14 +0900
parents 0572611fdcc8
children c4bab56944e8
line wrap: on
line diff
--- a/clang-tools-extra/clangd/test/CMakeLists.txt	Mon May 25 11:55:54 2020 +0900
+++ b/clang-tools-extra/clangd/test/CMakeLists.txt	Tue Jun 08 06:07:14 2021 +0900
@@ -11,8 +11,8 @@
 set(CLANGD_TEST_DEPS
   clangd
   ClangdTests
-  # No tests for these, but we should still make sure they build.
   clangd-indexer
+  # No tests for it, but we should still make sure they build.
   dexp
   )
 
@@ -21,7 +21,11 @@
   list(APPEND CLANGD_TEST_DEPS ClangdXpcUnitTests)
 endif()
 
-foreach(dep FileCheck count not)
+if(CLANGD_ENABLE_REMOTE)
+  list(APPEND CLANGD_TEST_DEPS clangd-index-server clangd-index-server-monitor)
+endif()
+
+foreach(dep FileCheck count not llvm-config)
   if(TARGET ${dep})
     list(APPEND CLANGD_TEST_DEPS ${dep})
   endif()