diff lld/MachO/CMakeLists.txt @ 207:2e18cbf3894f

LLVM12
author Shinji KONO <kono@ie.u-ryukyu.ac.jp>
date Tue, 08 Jun 2021 06:07:14 +0900
parents 0572611fdcc8
children 5f17cb93ff66
line wrap: on
line diff
--- a/lld/MachO/CMakeLists.txt	Mon May 25 11:55:54 2020 +0900
+++ b/lld/MachO/CMakeLists.txt	Tue Jun 08 06:07:14 2021 +0900
@@ -2,34 +2,60 @@
 tablegen(LLVM Options.inc -gen-opt-parser-defs)
 add_public_tablegen_target(MachOOptionsTableGen)
 
+include_directories(${LLVM_MAIN_SRC_DIR}/../libunwind/include)
+
 add_lld_library(lldMachO2
+  Arch/ARM.cpp
+  Arch/ARM64.cpp
+  Arch/ARM64Common.cpp
+  Arch/ARM64_32.cpp
   Arch/X86_64.cpp
+  ConcatOutputSection.cpp
   Driver.cpp
+  DriverUtils.cpp
+  Dwarf.cpp
   ExportTrie.cpp
   InputFiles.cpp
   InputSection.cpp
-  MergedOutputSection.cpp
+  LTO.cpp
+  MapFile.cpp
+  MarkLive.cpp
+  ObjC.cpp
   OutputSection.cpp
   OutputSegment.cpp
+  Relocations.cpp
   SymbolTable.cpp
   Symbols.cpp
   SyntheticSections.cpp
   Target.cpp
+  UnwindInfoSection.cpp
   Writer.cpp
 
   LINK_COMPONENTS
   ${LLVM_TARGETS_TO_BUILD}
   BinaryFormat
+  BitReader
   Core
+  DebugInfoDWARF
+  LTO
+  MC
+  ObjCARCOpts
   Object
   Option
+  Passes
   Support
+  TextAPI
 
   LINK_LIBS
   lldCommon
   ${LLVM_PTHREAD_LIB}
+  ${XAR_LIB}
 
   DEPENDS
   MachOOptionsTableGen
   ${tablegen_deps}
   )
+
+if(LLVM_HAVE_LIBXAR)
+  target_link_libraries(lldMachO2 PRIVATE ${XAR_LIB})
+endif()