diff tools/bugpoint-passes/CMakeLists.txt @ 77:54457678186b LLVM3.6

LLVM 3.6
author Kaito Tokumori <e105711@ie.u-ryukyu.ac.jp>
date Mon, 08 Sep 2014 22:06:00 +0900
parents 95c75e76d11b
children 1172e4bd9c6f
line wrap: on
line diff
--- a/tools/bugpoint-passes/CMakeLists.txt	Thu Dec 12 15:22:36 2013 +0900
+++ b/tools/bugpoint-passes/CMakeLists.txt	Mon Sep 08 22:06:00 2014 +0900
@@ -2,6 +2,18 @@
   set(EXCLUDE_FROM_ALL ON)
 endif()
 
+# If we don't need RTTI or EH, there's no reason to export anything
+# from this plugin.
+if( NOT LLVM_REQUIRES_RTTI )
+  if( NOT LLVM_REQUIRES_EH )
+    set(LLVM_EXPORTED_SYMBOL_FILE ${CMAKE_CURRENT_SOURCE_DIR}/bugpoint.exports)
+  endif()
+endif()
+
+if(WIN32 OR CYGWIN)
+  set(LLVM_LINK_COMPONENTS Core)
+endif()
+
 add_llvm_loadable_module( BugpointPasses
   TestPasses.cpp
   )