diff tools/llc/CMakeLists.txt @ 100:7d135dc70f03 LLVM 3.9

LLVM 3.9
author Miyagi Mitsuki <e135756@ie.u-ryukyu.ac.jp>
date Tue, 26 Jan 2016 22:53:40 +0900
parents afa8332a0e37
children 1172e4bd9c6f
line wrap: on
line diff
--- a/tools/llc/CMakeLists.txt	Tue Oct 13 17:49:56 2015 +0900
+++ b/tools/llc/CMakeLists.txt	Tue Jan 26 22:53:40 2016 +0900
@@ -1,3 +1,10 @@
+# Add GlobalISel to the dependencies if the user wants to build it.
+if(LLVM_BUILD_GLOBAL_ISEL)
+  set(GLOBAL_ISEL GlobalISel)
+else()
+  set(GLOBAL_ISEL "")
+endif()
+
 set(LLVM_LINK_COMPONENTS
   ${LLVM_TARGETS_TO_BUILD}
   Analysis
@@ -5,12 +12,14 @@
   CodeGen
   Core
   IRReader
+  ${GLOBAL_ISEL}
   MC
   MIRParser
   ScalarOpts
   SelectionDAG
   Support
   Target
+  TransformUtils
   )
 
 # Support plugins.