diff lib/Target/CMakeLists.txt @ 121:803732b1fca8

LLVM 5.0
author kono
date Fri, 27 Oct 2017 17:07:41 +0900
parents 1172e4bd9c6f
children
line wrap: on
line diff
--- a/lib/Target/CMakeLists.txt	Fri Nov 25 19:14:25 2016 +0900
+++ b/lib/Target/CMakeLists.txt	Fri Oct 27 17:07:41 2017 +0900
@@ -1,5 +1,7 @@
 list(APPEND LLVM_COMMON_DEPENDS intrinsics_gen)
 
+list(APPEND LLVM_TABLEGEN_FLAGS -I ${LLVM_MAIN_SRC_DIR}/lib/Target)
+
 add_llvm_library(LLVMTarget
   Target.cpp
   TargetIntrinsicInfo.cpp
@@ -15,3 +17,9 @@
   message(STATUS "Targeting ${t}")
   add_subdirectory(${t})
 endforeach()
+
+# Currently we do not allow libraries from lib to reference targets directly.
+# This property is used to enforce that convention. It is important because the
+# logic in llvm_map_components_to_libnames is order dependent on the target
+# libraries being created.
+set_property(GLOBAL PROPERTY LLVM_TARGETS_CONFIGURED On)