diff clang/unittests/CMakeLists.txt @ 236:c4bab56944e8 llvm-original

LLVM 16
author kono
date Wed, 09 Nov 2022 17:45:10 +0900
parents 79ff65ed7e25
children 1f2b6ac9f198
line wrap: on
line diff
--- a/clang/unittests/CMakeLists.txt	Wed Jul 21 10:27:27 2021 +0900
+++ b/clang/unittests/CMakeLists.txt	Wed Nov 09 17:45:10 2022 +0900
@@ -35,7 +35,9 @@
 add_subdirectory(Rewrite)
 add_subdirectory(Sema)
 add_subdirectory(CodeGen)
-add_subdirectory(Interpreter)
+if(HAVE_CLANG_REPL_SUPPORT)
+  add_subdirectory(Interpreter)
+endif()
 # FIXME: libclang unit tests are disabled on Windows due
 # to failures, mostly in libclang.VirtualFileOverlay_*.
 if(NOT WIN32 AND CLANG_TOOL_LIBCLANG_BUILD) 
@@ -45,3 +47,4 @@
 add_subdirectory(Rename)
 add_subdirectory(Index)
 add_subdirectory(Serialization)
+add_subdirectory(Support)