diff lib/ExecutionEngine/Interpreter/CMakeLists.txt @ 0:95c75e76d11b

LLVM 3.4
author Kaito Tokumori <e105711@ie.u-ryukyu.ac.jp>
date Thu, 12 Dec 2013 13:56:28 +0900
parents
children 54457678186b
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/lib/ExecutionEngine/Interpreter/CMakeLists.txt	Thu Dec 12 13:56:28 2013 +0900
@@ -0,0 +1,19 @@
+# Make sure that the path to libffi headers is on the command
+# line. That path can be a compiler's non-default path even when
+# FFI_INCLUDE_DIR was not used, because cmake has its own paths for
+# searching for headers (CMAKE_SYSTEM_INCLUDE_PATH, for instance):
+if( FFI_INCLUDE_PATH )
+  include_directories( ${FFI_INCLUDE_PATH} )
+endif()
+
+add_llvm_library(LLVMInterpreter
+  Execution.cpp
+  ExternalFunctions.cpp
+  Interpreter.cpp
+  )
+
+if( LLVM_ENABLE_FFI )
+  target_link_libraries( LLVMInterpreter ${FFI_LIBRARY_PATH} )
+endif()
+
+add_dependencies(LLVMInterpreter intrinsics_gen)